当前位置:→ 公式网 > 通达信公式 > 正文 ℃ 公式解密、改选股等业务 联系点击查看详情...

以下是通达信一线定江山叠加公式到主图公式主图源码(无源码的请下载附件导入)

一线定江山,叠加公式到主图

N:=5;

 M1:=3;

 M2:=3;

 QWX1:=HHV(CLOSE,30);

 QWX2:=LLV(CLOSE,30);

 QWX3:=CONST((QWX1+QWX2)/2);

 QWX4:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

 QWX5:=CONST((1-7/100)*(DMA(CLOSE,QWX4)));

 QWX6:=CONST((1+7/100)*(DMA(CLOSE,QWX4)));

 {KDJ}

 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

 KX:=SMA(RSV,3,1);

 DX:=SMA(KX,3,1);

 JX:=3*KX-2*DX;

 {MACD}

 DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*2+QWX3,COLORWHITE;

 DEA:=EMA(DIF,9),COLORYELLOW;

 MCD:=(DIF-DEA)*2+QWX3;

 DRAWBAND(MCD,RGB(120,0,100),QWX3,RGB(60,100,50));

 DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

分水岭:(EMA(CLOSE,30)+EMA(CLOSE,72))/2,LINETHICK2,COLORGREEN;

 M5:MA(CLOSE,N),COLORWHITE;

 M10:MA(CLOSE,M1),COLORYELLOW;

 M20:MA(CLOSE,M2),COLORFF00FF;

 VAR1:=IF(CLOSE>OPEN,CLOSE,OPEN);

 VAR2:=MEMA(CLOSE,5);

 VAR3:=ATAN((VAR2/REF(VAR2,1)-1)*100);

 VAR4:=IF(VAR3>0,VAR3,VAR3);

 VAR5:=(CLOSE/REF(CLOSE,1)-1)*100;

 VAR6:=VAR5<1.5 AND VAR5>-1.5;

今日之升★:LAST(VAR6,4,1) AND VAR5>2 AND VOL>REF(VOL,1),NODRAW,COLORYELLOW;

 DRAWTEXT(今日之升★,L/1.01,'★'),COLORYELLOW;

强势:IF(VAR4>=REF(VAR4,1) AND VAR4>=0,M10,DRAWNULL),COLORRED,LINETHICK2;

整理:IF(VAR4<REF(VAR4,1) AND VAR4>0,M10,DRAWNULL),COLORGREEN,LINETHICK2;

支撑:IF(PERIOD=5,IF(BARSLAST(CURRBARSCOUNT=5),QWX5,DRAWNULL),DRAWNULL),COLORCYAN;

阻力:IF(PERIOD=5,IF(BARSLAST(CURRBARSCOUNT=5),QWX6,DRAWNULL),DRAWNULL),COLORYELLOW;

 {柱型显示 分析家公式网}

STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;

 STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;

 {蓝}

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;

 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;

 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;

 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;

 {红}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;

 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;

 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;

 STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;

 {绿}

STICKLINE(CROSS(M5,EMA(C,3)),VAR1,(OPEN+CLOSE)/2,3,0),COLOR009900;

 STICKLINE(CROSS(M5,EMA(C,3)),VAR1,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;

 STICKLINE(CROSS(M5,EMA(C,3)),VAR1,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;

 STICKLINE(CROSS(M5,EMA(C,3)),VAR1,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;

 {灰}

STICKLINE(CROSS(EMA(C,3),M5),OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;

 STICKLINE(CROSS(EMA(C,3),M5),OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;

 STICKLINE(CROSS(EMA(C,3),M5),OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;

 STICKLINE(CROSS(EMA(C,3),M5),OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;

 STICKLINE(CROSS(JX,DX),OPEN,CLOSE,0.5,0),COLORYELLOW;

 STICKLINE(CROSS(DX,JX),OPEN,CLOSE,0.5,0),COLOR000099;

 


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
湘ICP备09016573号-3 湘公网安备43108102000039号
Copyright © 铭网科技,All Rights Reserved.
股票公式,股票指标,股票软件,股票知识

百度